Ad serving disrupted

Incident Report for Adnuntius System Status

Resolved

The CloudFlare issue has been resolved (https://www.cloudflarestatus.com/incidents/28r0vbbxsh8f).
We will now undertake a review of our systems, and make changes to prevent a similar outage in an external system from impacting our ad delivery performance.
Posted Jul 14, 2025 - 23:08 UTC

Update

Most ad request processing is back to normal now. We will continue to monitor this until the CloudFlare issue has been resolved.
Posted Jul 14, 2025 - 22:58 UTC

Monitoring

Ad requests are taking a long time to process and some may fail to return ads to the client browser due to the connection timing out.
The source of this has been identified as a failure in DNS lookups that is caused by a CloudFlare outage (https://www.cloudflarestatus.com/incidents/28r0vbbxsh8f).
We have taken action to prevent these DNS timeouts from impacting the ad request processing.
The CloudFlare issue has been identified and is being resolved by their engineers.
Posted Jul 14, 2025 - 22:38 UTC
This incident affected: Ad Serving.