Device targeting incorrectly matching in certain cases
Incident Report for Adnuntius System Status
Resolved
All line items and creatives that our monitoring identified as affected have now been updated, so please let us know if you still see anything unusual with device targeting. As a precaution we are updating everything in the system which will continue for a while longer.
The cause of the issue was ongoing work to improve device targeting ahead of some changes to the Chrome browser. The work involved shipping a codec to handle any line items or creatives using the previous targeting version until they could be converted to the new version. Unfortunately it turned out there was some targeting from versions even earlier than the previous one still in the system, which the codec handled by matching the wrong device type until they were updated.
Our sincere apologies to anyone whose campaigns were affected by this incident. We will shortly be conducting an analysis to figure out the exact sequence of events and how to prevent similar issues in the future.
Posted Dec 15, 2022 - 12:53 UTC
Monitoring
The majority of impacted line items and creatives have now been updated and are serving correctly.
Posted Dec 15, 2022 - 10:47 UTC
Identified
Certain categories of device targeting have been failing to match correctly for several hours due to a system update, resulting in them not delivering when they should have. Line items and creatives are being refreshed now which will start them delivering again.
Posted Dec 15, 2022 - 09:08 UTC
This incident affected: Ad Serving.